Account Servers Downtime

Incident Report for Revelplay Servers

Update

We are continuing to work on a fix for this issue.
Posted Sep 28, 2022 - 11:38 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 08, 2022 - 22:18 UTC
This incident affects: Accounts Servers.